Annoying sound after returning to VC.

All problems and technical questions concerning our Cessna O-1/L-19 Bird Dog are discussed here.
TigerTwin
Posts: 6
Joined: 07 Feb 2009, 12:33

Annoying sound after returning to VC.

Post by TigerTwin » 08 Jan 2010, 06:09

First I really want to congratulate you guys to a terrific Cessna Bird Dog. After the faboulus Saab Safir I had very high expectations. And I was not dissappointed!
However I have a problem that has come to haunt me with several planes, not only SibWings, but also Citabria for ex. After loading of plane and leaving the VC view (where it is silent at first) to go to locked spot view and then back to VC I get a terribly annoying noise. How do I remove that sound? Where does it come from?

My specs: OS: Windows 7 (it was the same problem with Windows Vista!)
Intel 3,2 GHz, NVIDIA GeForce GTX 295, ASUS P6T DeLuxe motherboard.

User avatar
Alex
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia
Contact:

Re: Annoying sound after returning to VC.

Post by Alex » 12 Jan 2010, 23:43

How does this noise sound like ?
Alex Petrochenko
SibWings developer

TigerTwin
Posts: 6
Joined: 07 Feb 2009, 12:33

Re: Annoying sound after returning to VC.

Post by TigerTwin » 13 Jan 2010, 04:03

It sounds like a big diesel truck idling and it affects my Cessna Bird Dog, Scout, Citabria, Decathlon and Grumman Goose. But not my Safir, A2A Cub, Cessna 172, Beaver and Maule.
It starts when I go from locked spot view to virtual cockpit (or 2D cockpit). Even when my engine is off.
Spooky! I guess you can't help me there.

sonny
Posts: 3
Joined: 15 Jan 2010, 03:38

Re: Annoying sound after returning to VC.

Post by sonny » 15 Jan 2010, 21:08

I have the same problem.

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 19 Jan 2010, 16:26

Same here - but only Birddog-related.

teeboy
Posts: 13
Joined: 26 Dec 2009, 22:17

Re: Annoying sound after returning to VC.

Post by teeboy » 20 Jan 2010, 21:28

Is this the old 'fuel pump' sound that seems to have plagued FSX for ages? Try turning sound off then back on (Q key) and see if that fixes it. I have had similar issues with several add-ons and this always sorts that out.

I guess good old Microsoft/ ACES could have fixed it if the plug hadn't been pulled...

Nick.

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 20 Jan 2010, 22:56

Alex wrote:How does this noise sound like ?
Hi
It is not the fuel pump sound,Nick.
I've cecked all the Birddog soundfiles and it seems to be one of the "noncombust.wav"-files.
Can't exactly say wich one

User avatar
Alex
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia
Contact:

Re: Annoying sound after returning to VC.

Post by Alex » 20 Jan 2010, 23:07

Can someone describe how to repeat it on my PC ? :)
Alex Petrochenko
SibWings developer

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 21 Jan 2010, 00:25

Alex wrote:Can someone describe how to repeat it on my PC ? :)
Hi Alex
Stop the Birddog-engine in virtual cockpit .
Switch through outside views.
Switch back to virtual cockpit view and the sound is probably there

User avatar
Andrey
Site Admin
Posts: 834
Joined: 18 Sep 2005, 12:51
Location: Siberia
Contact:

Re: Annoying sound after returning to VC.

Post by Andrey » 14 Mar 2010, 13:22

Hello everyone!

Sorry for long time fixing this. Unzip file attached into your
F:\FSX\SimObjects\Airplanes\SibWings_Cessna_BirdDog\sound folder

files mwbdog_noncombust1.wav
Xmwbdog_noncombust1.wav
mwbdog_noncombust2.wav
Xmwbdog_noncombust2.wav

can be deleted from there.

This fix will be included into update coming.

Andrey
Attachments
sound.zip
(140 KiB) Downloaded 229 times
Image
We are at facebook: facebook.com/sibwings

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 15 Mar 2010, 20:13

This probleme has been fixed from bad to worse.
Now I have this soundproblem in outside- frontal view.
Also in tower- view.
No matter,whether the engine is running or not.
And the plane starts bouncing up and down.

User avatar
Andrey
Site Admin
Posts: 834
Joined: 18 Sep 2005, 12:51
Location: Siberia
Contact:

Re: Annoying sound after returning to VC.

Post by Andrey » 15 Mar 2010, 21:55

Hmm strange, it's all okay here, check files one more time pls, or wait for update, we'll include this fix.

Andrey
Image
We are at facebook: facebook.com/sibwings

snave
Posts: 220
Joined: 03 Sep 2006, 01:21
Location: United Kingdom

Re: Annoying sound after returning to VC.

Post by snave » 16 Mar 2010, 03:53

sangsom wrote:This probleme has been fixed from bad to worse.
Now I have this soundproblem in outside- frontal view.
Also in tower- view.
No matter,whether the engine is running or not.
And the plane starts bouncing up and down.
Please show content of the FSX .cfg. (Exclude Gauge permissions and any information that offers personal detail, there shouldn't be any, but who knows...)
Simon Evans

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 16 Mar 2010, 15:32

snave wrote:
sangsom wrote:This probleme has been fixed from bad to worse.
Now I have this soundproblem in outside- frontal view.
Also in tower- view.
No matter,whether the engine is running or not.
And the plane starts bouncing up and down.
Please show content of the FSX .cfg. (Exclude Gauge permissions and any information that offers personal detail, there shouldn't be any, but who knows...)
After using a new FSX.CFG the problems remain unchanged.
Attached the new one.Sorry to bother you.
Thank you.
Helmut
Edit:Not been able to upload an attachment

snave
Posts: 220
Joined: 03 Sep 2006, 01:21
Location: United Kingdom

Re: Annoying sound after returning to VC.

Post by snave » 16 Mar 2010, 17:21

Copy/Paste will work, inside a quote box
Simon Evans

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 16 Mar 2010, 21:49

snave wrote:Copy/Paste will work, inside a quote box
Ok-here it comes :The new build FSXcfg

Code: Select all

[SOUND]
AmbientUIMusicVolume=-6.000000
SOUND_FADER1=0.500000
SOUND_FADER2=0.500000
SOUND_FADER3=0.500000
SOUND_FADER4=0.500000
AmbientUIMusic=FSX01
PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
UISound=1
AmbientUI=0
[Display]
ChangeTime=4.000000
TransitionTime=4.000000
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
BLOOM_EFFECTS=0
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=40
UPPER_FRAMERATE_LIMIT=26
WideViewAspect=False
[Main]
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
ProcSpeed=9392
PerfBucket=7
Maximized=1
Location=444,178,1476,964,\\.\DISPLAY1
HideMenuNormal=0
HideMenuFullscreen=1
[PANELS]
IMAGE_QUALITY=1
DEFAULT_VIEW=0
QUICKTIPS=1
PANEL_OPACITY=100
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
[Weather]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherServerAddress=fs2k.zone.com
WeatherServerPort=80
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=1
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=3
DETAILED_CLOUDS=1
CLOUD_COVERAGE_DENSITY=8
THERMAL_VISUALS=0
[DISPLAY.Device.NVIDIA GeForce 9600 GT.0]
Mode=1920x1200x32
Anisotropic=1
AntiAlias=1
[AccelerationPack]
ControlsFirstRun=0
HomePageFirstRun=0
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
[SlewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[SlewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[SlewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
[Trusted]

E:\MS-FlightSimulator X\GAUGES\birddog.DLL.atibeqankaberikarirwlitbuuqanwckicnionho=2
[GRAPHICS]
SHADER_CACHE_PRIMED=1693500672
D3D10=0
TEXTURE_MAX_LOAD=1024
NUM_LIGHTS=8
AIRCRAFT_SHADOWS=0
AIRCRAFT_REFLECTIONS=1
COCKPIT_HIGH_LOD=1
LANDING_LIGHTS=1
AC_SELF_SHADOW=0
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=1
[USERINTERFACE]
ShowAllACPaintSchemes=0
SelectAircraftManufacturer=Alle
SelectAircraftPublisher=SibWings Lab.
SelectAircraftType=Alle
PageID=1
OpenATCOnCreate=0
SHOW_MISSION_CAPTIONS=0
PAUSE_ON_LOST_FOCUS=1
PROMPT_ON_EXIT=1
SITUATION=FLIGHTS\OTHER\FLTSIM
Map_Orientation=2
[ATC]
ShowATCText=1
COMM_MSG_NONE_COLOR=FFFFFFFF
COMM_MSG_ATC_USER_COLOR=FFB6FFB6
COMM_MSG_USER_ATC_COLOR=FFFFD21B
COMM_MSG_ATC_AI_COLOR=FF00FF00
COMM_MSG_AI_ATC_COLOR=FFFF7840
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
PilotVoice=0
[PointOfInterestSystem]
CycleSetting=0
[MULTIPLAYER]
condAccoutPassword=0
[SCENERY]
LENSFLARE=1
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=5
[TrafficManager]
AirlineDensity=20
GADensity=43
FreewayDensity=11
ShipsAndFerriesDensity=40
LeisureBoatsDensity=40
IFROnly=0
AIRPORT_SCENERY_DENSITY=1
[TERRAIN]
LOD_RADIUS=3.500000
MESH_COMPLEXITY=98
MESH_RESOLUTION=23
TEXTURE_RESOLUTION=29
AUTOGEN_DENSITY=3
DETAIL_TEXTURE=1
WATER_EFFECTS=4
[AContain]
ShowLabels=0
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
[INTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[REALISM]
PFactor=0.000000
Torque=0.000000
GyroEffect=0.000000
CrashTolerance=0.000000
General=0.000000
UnlimitedFuel=True
AllowEngineDamage=False
TrueAirspeed=False
AutoCoord=False
RealMixture=False
StressDamage=False
GEffect=False
ManualLights=False
GyroDrift=False
CrashWithDyn=False
CrashDetection=False
AutoTrim=False
[SIM]
SYSCLOCK=1
[STARTUP]
DEMO=0
SHOW_OPENING_SCREEN=1
STARTUP_DEMO=
LoadWindow=1
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=1570
[Misc]
Com_Rate=7

snave
Posts: 220
Joined: 03 Sep 2006, 01:21
Location: United Kingdom

Re: Annoying sound after returning to VC.

Post by snave » 17 Mar 2010, 01:03

As I suspected, the cause is system resource related. Your 9600GT card is simply starving the visual resources, leaving none for the rest of your system to cope with the requirements of the sound cones in FSX - priority is offered first to visuals and only what remains can be directed to sound management. 1920x1200x32 would normally require something considerably `meatier`. How much VRAM on the card?

BUT, as a first step, try downscaling the massive amount of AI you have running - You can knock off ALL Airline, GA, Road, Ship and Boat traffic and you might find that alone frees up enough resources to prevent the sound hanging. After that you may find respite from reconsidering the graphic settings. One which does make substantial difference to resources in the sim, but which makes for little visual difference in anything other than mountainous settings is Mesh Complexity. You have it at 98%. Try 49% and see if that makes a difference.

The reason this is happening when you return to the VC indicates that it is a visual issue, not sound, but to be on the safe side:

Onboard sound card or dedicated PCI device? Updated drivers? If you have a separate sound card have you DISabled any onboard sound in the system BIOS?

Try these and report back. The Bird Dog is extremely complex in its visual representations and you are pushing limits is all.
Simon Evans

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 17 Mar 2010, 22:31

Hello snave
Thank you for your response,but -
I respectfully disagree.the cause is not system resource related.
Following all your suggestions (Traffic all zero,water-zero aso) I've got the following result :
Nothing has changed. Not the crazy sound and not the two times bouncing with crash-sound.
By the way - I have amongst others the PMDG 747-400 and A2A P-47 with accusim installed.This are extremely complex planes,
not the little Birddog. They are running happily in FSX with my settings and hardware without any issue.
A Sibwing developer should have a look at FSX-main folder-sibwings-birddog-sound.After deacctivating this folder the sound-issue has gone.
Now I miss the unbelievable ashtray sound.
Helmut
P.S. 9600GTOC 1GB DDr 3,creative SB X-Fi extreme
"1920x1200x32 would normally require something considerably `meatier` " = nonsence

User avatar
Alex
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia
Contact:

Re: Annoying sound after returning to VC.

Post by Alex » 17 Mar 2010, 23:27

I can't reproduce this bug on my PC.
I had only one strange looping sound with shutdown engine "Top-Down" view selected.
This sounds was:

Code: Select all

FSX\SimObjects\Airplanes\SibWings_Cessna_BirdDog\sound\mwbdog_noncombust1.wav
FSX\SimObjects\Airplanes\SibWings_Cessna_BirdDog\sound\mwbdog_noncombust2.wav
FSX\SimObjects\Airplanes\SibWings_Cessna_BirdDog\sound\xmwbdog_noncombust1.wav
FSX\SimObjects\Airplanes\SibWings_Cessna_BirdDog\sound\xmwbdog_noncombust2.wav
Try to move this files temporarily and check if sound bug is gone.
Alex Petrochenko
SibWings developer

sangsom
Posts: 26
Joined: 28 Nov 2009, 15:11

Re: Annoying sound after returning to VC.

Post by sangsom » 19 Mar 2010, 20:59

Checked. No luck.The sound-bug is still there.Beside others.
When all is said and done - a nice VC is not enough.
This software has one bug to many.
Only a comprehensive update can help.
Helmut

Post Reply