Solution to "Dissapearing Safir"

All problems and technical questions concerning our SAAB 91 Safir X are discussed here.
Post Reply
User avatar
Voyager30
Posts: 176
Joined: 10 May 2006, 01:14
Location: Ulricehamn, Sweden
Contact:

Solution to "Dissapearing Safir"

Post by Voyager30 » 28 Mar 2010, 10:18

I have found a possible solutions to the problem where the Safir dissapears after about 10 seconds.
I had to reinstall my FSX due to messed up effects and other things and uninstalled all my addons, and Acceleration, SP1 and finally FSX after this did I delete the FSX folder under "My programs"- This just to have a clean base to stand on when the reinstall was made.

After I reinstalled all again was i faced with the "Dissapearing Safir" syndrom.
Searching this forum stated that the problem is related to a corrupt Simconnect installation which I thought quite impossible - I had just reinstalled FSX how could it be bad?
Making the simconnect.ini test showes that data flows from the module.

Further "googling" did at last give me this page http://a2asimulations.com/forum/viewtop ... 65&t=19370 and the section "I can not see Heidi or some 2D panels".
In frustration did I follow the steps - even if took a while :?
After this is my Safir working again as well as another addon with a problem in fact also related to SimConnect.

So bottom line - even with what i thought was a clean installation of the FSX was in fact a partial reinstallation - it seems like the Uninstall provided with FSX don't take care about all files/folders correctly.
My estimation is that by manually removing the Simconnect folders under "C:\windows\WinSxS" was the key - FSX installation program did really need to put in the SimConnect files again as the actually was missing. The first reinstall detected possibly that the files was present , due to that fsx uninstalled left them in place, and did not replace them.

It's a bit time consuming to do the reinstall process but it's worth it.

Regards

Gerth
Image

Post Reply