Installation error

All problems and technical questions concerning our SAAB 91 Safir X are discussed here.
Post Reply
6297J
Posts: 23
Joined: 03 Sep 2006, 12:42

Installation error

Post by 6297J » 09 Nov 2008, 10:58

On trying to install for FSX I get the following error -

Unable to execute file:
C:\Program Files (x86)\Microsoft Games\Microsot=ft Flight Simulator X\SibWings\Safir\bin\init.exe

Create Process failed; code 5.
Access is denied


I have Vista Ultimate 64 bit and have tried running the install as administrator.

User avatar
Alex
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia
Contact:

Re: Installation error

Post by Alex » 09 Nov 2008, 11:19

Hi,

After installation try to manually run "Start->All Programs->SibWings->FSX SAAB 91 Safir->Activation".

I'll try to fix it on next update.

Thanks
Alex Petrochenko
SibWings developer

6297J
Posts: 23
Joined: 03 Sep 2006, 12:42

Re: Installation error

Post by 6297J » 09 Nov 2008, 11:46

Thanks Alex, I tried that. Also tried running init.exe from it's install location but got the same error message.
I'll keep checking back to see if it's been fixed. I'd hate to lose the Safir after finally switching to a new PC that can handle FSX :cry:
Last edited by 6297J on 10 Nov 2008, 15:45, edited 1 time in total.

User avatar
Alex
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia
Contact:

Re: Installation error

Post by Alex » 09 Nov 2008, 11:56

did you run activation program as administrator ? :) because this error say you haven't permission for edit registry...
Alex Petrochenko
SibWings developer

6297J
Posts: 23
Joined: 03 Sep 2006, 12:42

Re: Installation error

Post by 6297J » 09 Nov 2008, 13:33

I did, yes. I tried doing everything as administrator and the error message was the same. It's the only add-on I've had an issue with since I began installing FSX and all the various sceneries and aircraft yesterday morning.

tigge
Posts: 23
Joined: 07 Nov 2008, 00:48

Re: Installation error

Post by tigge » 09 Nov 2008, 13:45

Hi,

Maybe the virus protection igot the same indication (Unable to execute file:
X\SibWings\Safir\bin\init.exe.

You can have a look in my thread (Paying Problem...) in this forum, i have a screendump
there that maybe is the same as yours.
I had to deactivate the virus protection during installation then it went good, every thing in place.

Per E

6297J
Posts: 23
Joined: 03 Sep 2006, 12:42

Re: Installation error

Post by 6297J » 10 Nov 2008, 15:44

tigge wrote:Hi,

Maybe the virus protection igot the same indication (Unable to execute file:
X\SibWings\Safir\bin\init.exe.

You can have a look in my thread (Paying Problem...) in this forum, i have a screendump
there that maybe is the same as yours.
I had to deactivate the virus protection during installation then it went good, every thing in place.

Per E
Thank you. I did have that error at first but stopped running AVG and Defender which removed the Virus alert but not the init.exe problem. I've tried installing in different modes, as different users and still get the same issue. I don't know what else to try.

VTTS
Posts: 5
Joined: 13 Nov 2008, 04:14

Re: Installation error

Post by VTTS » 13 Nov 2008, 04:18

Hi,

I am also having this problem, it looks like a very nice plane but I cant fly it, not even install it. I have tried everything I can think of, I wondered if you had an idea on when you might have a fix for this, as I would really like to fly it. I buy a lot of payware a/c, this is the first one that I have not actually been able to install.

P.S MY anti-virus (AVG) also complains about a "virus". I have even turned this and windows defender off and tried it then, but still no luck!

Thanks in advance.

User avatar
Andrey
Site Admin
Posts: 834
Joined: 18 Sep 2005, 12:51
Location: Siberia
Contact:

Re: Installation error

Post by Andrey » 13 Nov 2008, 15:13

Hello Guys,

We'll try to find out, honestly I can't even suppouse where problem is... will try to install AVG today...

Andrey
Image
We are at facebook: facebook.com/sibwings

User avatar
Alex
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia
Contact:

Re: Installation error

Post by Alex » 13 Nov 2008, 15:17

Hi guys,

I've been tested our installer on machine with AVG, and it's really didn't wont to work.
Found the solution, just turn off "Resident Shield" AVG module and run Activation programm or reinstall Safir X. :)
Attachments
untitled.jpg
untitled.jpg (64.58 KiB) Viewed 3735 times
Alex Petrochenko
SibWings developer

VTTS
Posts: 5
Joined: 13 Nov 2008, 04:14

Re: Installation error

Post by VTTS » 13 Nov 2008, 21:55

Hi Alex,

Thank you so much! This method worked, previously I had just shut down the User Interface of avg but NOT the resident shield. It went through and installed properly. Thanks for taking the time to test this at your end, I am now off to fly this beautiful looking plane.

Thanks again,

James.

6297J
Posts: 23
Joined: 03 Sep 2006, 12:42

Re: Installation error

Post by 6297J » 14 Nov 2008, 10:16

Yes, installation worked for me too! Thank you.

However, I now get an error message - 'Cannot set allocations' when I try to select any of the models and if I try to fly any of them the textures disappear (except a little brown torso!) after a few seconds and it all goes quiet before I get a black screen. When I get out of FSX the 'Cannot set allocations' message is still there. I have FSX SP2.

I thought maybe the files had been updated following the earlier reports of crashing but the installation file I downloaded this morning is still version 0.0.0.0

User avatar
Andrey
Site Admin
Posts: 834
Joined: 18 Sep 2005, 12:51
Location: Siberia
Contact:

Re: Installation error

Post by Andrey » 14 Nov 2008, 17:05

Hello there,

We are working on problem, looks like it's something depends on simconnect.dll if something installed wrong (windows, FSX, SP1, SP2 etc.) simconnect doesn't work, and safir gauges (sounds visual) doesn't work... very few users have such bug, (less then 1% I can say.. in most cases SP2 reinstal was help)... the comic of situation is that one of them is I'm :]


Andrey
Image
We are at facebook: facebook.com/sibwings

6297J
Posts: 23
Joined: 03 Sep 2006, 12:42

Re: Installation error

Post by 6297J » 14 Nov 2008, 17:26

Andrey wrote:Hello there,

We are working on problem, looks like it's something depends on simconnect.dll if something installed wrong (windows, FSX, SP1, SP2 etc.) simconnect doesn't work, and safir gauges (sounds visual) doesn't work... very few users have such bug, (less then 1% I can say.. in most cases SP2 reinstal was help)... the comic of situation is that one of them is I'm :]


Andrey
Sorry to hear that Andrey. It's nice to know I'm not alone though :wink: (and that you're working on it)

By the way. Mine is a brand new PC with a virgin installation of FSX and Acceleration (FSX Gold). The Safir is one of the first add-ons I'm installing.

Post Reply