Small problem

All problems and technical questions concerning our SAAB 91 Safir X are discussed here.
Post Reply
Posts: 2
Joined: 26 Jan 2013, 20:26

Small problem

Post by doofus » 27 Jan 2013, 02:42

Hi, I'd firstly just like to say thanks to SibWings for such a fantastic add-on, I only bought it today and I'm totally hooked on my new Safir !

I made my Safir X purchase from JustFlight today and got it installed and working no problem. After installation I saw that D-EBED was not included in the JustFlight version of the installer so I downloaded the patch ( safirx-debed.exe, 12.4 mb ) which installed just great but when I starteded FSX and tried to use D-EBED I was asked for a fingerprint code key but JustFlight didn't supply me with any codes at all. Their security just required me to login using my JustFlight store login details during the initial Safir installation, no code key was required.

I then downloaded the latest full Safir installer as suggested before on this support forum ( safirx.exe 3.0.2, 65.2 mb ) but when trying to re-install using this I was asked again for a code key and as I already mentioned, I wasn't given a code key by JustFlight.

Could the free D-EBED be just for folks that bought directly from SibWings ? The only code I have is my order number from JustFlight which I'll happily provide if proof of purchase is required. Vanilla Safir X is great but I'd love to try out D-EBED, those screenshots look beautiful !

Thanks in advance for any help with this small problem.


User avatar
Site Admin
Posts: 750
Joined: 18 Sep 2005, 01:08
Location: Moscow, Russia

Re: Small problem

Post by Alex » 30 Jan 2013, 14:00

Hello Mark,

Sorry for long delay with answer.

Strange behavior, because safirx-debed.exe just add one model to Airplanes folder and don't change any other file.
Please try to :
1. Deinstall all Safir installations.
2. Install Safir from JustFlight pack.
3. Install safirx-debed.exe update pack.
4. Run FSX with Safir and check.

Waiting for a news!
Alex Petrochenko
SibWings developer

Posts: 2
Joined: 26 Jan 2013, 20:26

Re: Small problem

Post by doofus » 30 Jan 2013, 21:29

Hi Alex, thanks for your reply.

Doing a deinstall then reinstall and then the D-EBED has fixed my problem !! It is strange behaviour because I had already tried a fresh Safir install but the debed patch still asked for a code. After the deinstall the 2nd time I found a SibWings folder that was still in my FSX folder so deleted that manually and I also redownloaded the safirx-debed.exe.

Well whatever went wrong the 1st time didn't happen on the 2nd time! D-EBED is great and I'm so pleased I now have it working. Thanks for your help, I don't think I would have tried a de/re install again after it didn't work the 1st time.

Kind Regards


Post Reply